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Computer Essentials 

Software 

 

You might have the fastest computer sitting on your desk in front of you, however, without 

software the computer will do nothing more than take up space. The computer hardware on 

its own has no intelligence and therefore must be supplied with instructions to perform any 

task.  

 

Software or programs, consist of step-by-step instructions that tell the computer how to 

perform a task. 

 

All software can be divided into two categories – operating system software and application 

software. 

 

Operating System Software 

 

Operating System (OS) software is a program that controls the computer and enables it 

to run applications software (discussed further down). Systems software allows the 

computer to manage its internal resources. 

 

This software is designed to allow the computer system to manage its own resources (disks, 

monitor, keyboard, and printer). This software runs the basic computer operations - it tells 

the hardware what to do and how, and when to do it. Applications software cannot run 

without system software. 

 

Common desktop operating system software includes: 

 

 MS Windows – provides an easy interface between the computer 

and the user. It uses pictures (graphical representations) which 

look like push buttons on the screen and you can use the mouse 

to press them. This interface is known as a Graphical User 

Interface (GUI).  

 

MS Windows comes in a variety of versions. It has been updated over the years to 

make it more powerful and easier to use.  
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 Macintosh Operating System (Mac OS) – is the standard 

operating for Apple Corporation’s Macintosh computers.  

Like Windows, the MAC OS has a GUI interface. 

 

Besides, MS Windows and MAC OS there are other operating systems for example Linux, 

Unix and OS/2 Warp. 

 

Mobile devices, such as tablets and smartphones also include operating systems that provide 

a GUI and can run applications. Common mobile operating systems include Android, iOS 

(for iPads & iPhones), and Windows Phone. These operating systems are developed 

specifically for portable devices and therefore are designed around touchscreen input. 

 

Applications Software 

 

Applications software are programs that help the user carry out specific tasks on the 

computer. Such software has been written for a specific application - such as word-

processors, spreadsheets, databases and presentation software. 

 

Application software falls into two categories: 

1. Tailor-made (or custom-written) software – is software designed for a 

particular customer. Typically individual computer programmers or software houses 

are contracted to develop computerised systems for companies and organisations. 

 

2. Off-the-Shelf (or packaged) software – is software designed for use by the 

general public. Typically off-the-shelf software is available from all software selling 

shops. Large software houses develop this software. 

 

 

Off-the-shelf software includes: 

 Word-processing programs (e.g. MS Word, Writer) – used to prepare text-based 

documents such as letters, memos, reports etc. 

 

 Spreadsheet programs (e.g. MS Excel, Calc) – used to analyse and summarise 

numerical data. Spreadsheets are commonly used in accounting environments to 

prepare balance sheets and financial reports. 

 

 Database programs (e.g. MS Access, Base) – used to organise and manage large 

quantities of data. Databases enable efficient manipulation of data.  
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 Presentation graphics programs (e.g. MS PowerPoint, Impress) – used to 

organise text and numeric data in an appropriate format to be displayed to a group 

of people. Typically presentations are used in the preparation of on-screen displays, 

overhead transparencies and 35mm slides. 

 

 Photoediting programs (e.g. MS PhotoEditor, Adobe PhotoShop, GIMP) – used to 

alter images and graphics. These programs are used to change the size of pictures, 

crop pictures, adjust the colours of pictures etc. 

 

 Desktop publishing programs (e.g. MS Publisher, Adobe InDesign) – used to 

prepare high quality printed material e.g. flyers, invitations, posters, reports, 

magazines, and books. 

 

 Internet Web Browsers (e.g. MS Internet Explorer, Google Chrome, Mozilla 

Firefox, Opera) – used to locate and display information at Web sites. Browsers 

display Web pages with text, graphics, sounds and video-clips. 

 

 Communications software (e.g. MS Outlook, Mozilla Thunderbird) – used for the 

transmission of electronic messages or documents between different computers. 

 

 Social Networking websites (e.g. Facebook, LinkedIn) – allow users to be part 

of a virtual community. These websites provide users with simple tools to create a 

custom profile with text and pictures. A typical profile includes basic information 

about the user, photo albums, videos and comments published by the user. People 

use social networking sites to add friends, send messages to other users, and leave 

comments directly on friends' profiles. Some people join special interest groups on 

social networking sites. 

 

 Mobile applications (or mobile apps) – are software programs designed to run on 

smartphones, tablets and other mobile devices. These programs are usually 

available through application distribution platforms (e.g. Apple App Store, Google 

Play, Windows Phone Store etc.). Some mobile apps are free, while others must be 

bought. Mobile apps include email, calendar, contacts, weather information, 

location based services, banking, order-tracking and ticket purchases. 
 

Most of the above software is installed on desktops and computers and can be used without 

an Internet connection. However, more and more software (e.g. Microsoft Office 365, Google 

Apps, Adobe) is also available online. For example, you can create and edit a document 

online using Microsoft Office 365 or Google Docs.  

 

Types of Software Licences 

 

 Propriety software – is software whose rights are owned by an individual or 

business, usually a software developer. The ownership is protected by the copyright, 

and the owner expects you to buy a copy in order to use it. The software cannot 

legally be used or copied without permission. 

Nearly all applications are licensed rather than sold. There are a variety of different 

types of software licenses. Some are based on the number machines on which the 

licensed program can run whereas others are based on the number of users that can 

use the program. Most personal computer software licenses allow you to run the 

program on only one machine and to make copies of the software only for backup 
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purposes. Some licenses also allow you to run the program on different computers 

as long as you don't use the copies simultaneously. 

 

 Open source software – is freely available to the public. The programmer creates 

a program and makes it available for others to use without cost. Other programmers 

are also free to modify the source code and redistribute the modifications to users 

and developer community. Open source programs are often developed as a 

community rather than by a single organisation. 

 

 Trial version software – refers to software which consumers can try before they 

buy. Trial versions of software usually contain all the functionality of the regular 

version, but can only be used for a limited time (e.g. 30-day trial). 

 

 Shareware software – is copyrighted software that is distributed free of charge but 

requires users to make a contribution in order to receive technical help, 

documentation or upgrades. 

Shareware is inexpensive because it is usually produced by a single programmer and 

is offered directly to customers via the Internet. Thus, there are practically no 

packaging or advertising expenses. 

 

 Freeware software – is software that is available free of charge. Although it is 

available for free, the author retains the copyright, which means that you cannot do 

anything with it that is not expressly allowed by the author. Usually, the author allows 

people to use the software, but not sell it. 

 

 

End-User Licence Agreement (EULA) 

 

Users have to purchase the appropriate software licences to use propriety software.  

 

Shrink-wrap licences/End User Licence Agreements 

(EULA) – are printed licenses found inside software 

packages. Users are duty bound to use the software 

according to the conditions set out in the license sheet. 

There is no need for users to sign up any contracts with 

the software house. Users are encouraged to send the 

registration card included in the package. This registration 

entitles users to information and minor upgrades that are 

released from time to time by the software manufacturer. 

 

The Network 

 

Over the past years, millions of personal computers have been connected together to form 

computer networks. These networks facilitate the communication of data between different 

computers and sharing of resources. 
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A network consists of a group of computers and other peripherals (printers, scanners etc.) 

connected to each other.  

 

The purposes of network include: 

 

 Sharing of data – Networking enables several computer users to share data. Thus 

individual users can work on the same data at the same time. Depending on the 

configuration of the network, users work on real time updated data. 

 

 Sharing of peripheral devices – Networking enables several computer users to 

share laser printers, scanners, modems etc. Typically, several computer users in the 

same office are served by a single printer. This is cost effective for organisations with 

many computer users. 

 

 Sharing of programs – Networking enables several computer users to share the 

same programs. In most organisations, people make use of the same software. 

Rather than purchasing individual software packages for each computer user, 

organisations purchase network versions of the program. 

 

 Efficient communication – Networking enables efficient exchange messages and 

documents between several computer users. Networking eliminates the typical 

delays encountered with standard inter-office mail delivery or telephone calls. 

 
Intranet 
 
An intranet is an organisation’s private network that uses the infrastructure and standards 

of the Internet and World Wide Web. It is a website accessible only by the organisation’s 

members, employees or other persons with authorisation. 

 

When an organisation develops a public website on the Internet, it is making selected 

information available to the general public. When it creates an intranet, it is making selected 

information available only to authorised personnel. 

 

An intranet's Web site looks and acts just like any other Web sites, but the firewall 

surrounding an intranet prohibits unauthorized access. Intranets enable employees to have 

quicker access to internal information and to share knowledge so that they can do their jobs 

better. 

 

 

Virtual Private Network 

 

A Virtual Private Network (VPN) is a private network that uses the Internet 

to connect remote sites or users together. This technology is particularly useful 

for employees who need to access office data from their laptops at 

home and other locations. Data travels securely through the 

VPN technology.  

 

Businesses often use VPNs to communicate across multiple 

locations. For example, a large company that has offices in several cities may need to send 

data to the different locations via the Internet. To keep the information secure, the company 

sets up a VPN. 

 
 

 



Form 10 ICT 2017/2018 

 

Page 7 of 43 
 

Data Transfer Rate 

 

The data transfer rate is commonly used to measure how fast data is transferred from 

one location to another. 

 

Data is transmitted in characters or collections of bits. The transmission speed of data is 

measured in:  

 bps – stands for bits per second. 8 

bits = 1 character (Letter ‘A’ = 8 

bits).  

 kbps – stands for kilobits per second 

or 1000 bits per second. A 56.6K 

modem technically transmits 56,600 

bits per second of data. 

 mbps – stands for megabits per 

second or 1,000,000 bits per second. 

 gbps – stands for gigabits per 

second. 1Gbps is equal to 

1,000,000,000 bits per second. 

 

 

 

 

Downloading / Uploading 

 

Downloading refers to the transfer of data from a server to a local computer. For example 

when you view a webpage, the source code of a webpage is copied to your browser from a 

server across the Internet. Another example is when you download a document from 

Internet to your computer. When downloading files, the larger the file, the more time it 

takes to complete the transfer. 

 

Uploading refers to the transfer of data from a local computer to a server. For example, 

you can create a website and then upload this from your computer to your web server.  

 

 

 

Internet Connection Services 

 

Computers can be connected in different ways to the Internet.  

 

 Dialup connection – is a form of Internet access that uses telephone lines. The 

computer uses a special device called a modem that dials a telephone number and 

connects to an Internet Service Provider (ISP). Once connected users can browse 

the web, access emails etc.  

 

Dial-up connections are inexpensive compared to broadband connections. However 

data transfer over dial-up is slower compared to broadband connections. Another 
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disadvantage of dial-up connections is that no voice calls can be made/received 

through the phone line when this is being used for Internet. 

 

Internet Service Providers (ISPs) are companies that sell the services of their 

Internet server to stand-alone computer users. 

 

 Broadband connection – is a connection that enables fast data transfer rates 

between computers connected to Internet. A broadband connection is a permanent 

‘always-on’ connection to Internet. Being an ‘always-on’ connection makes 

computers more prone to intruder (or hacker) attacks. Firewalls are installed to 

prevent such attacks. Typically a user pays a flat-rate monthly fee when subscribing 

to a broadband connection. 

 

Broadband connections are available through a phone line (ADSL), a cable, Wi-Fi, 

WiMax, a mobile phone and satellite. 

 

Asynchronous Digital Subscriber Line (ADSL) broadband – is a broadband connection 

that uses a modem and the telephone line system to connect a computer to Internet. 

The ADSL modem is different from a dial-up modem. Through ADSL, a user can use 

the same phone line to connect to Internet and make a voice call at the same time. 

ADSL connections are faster compared to dial-up connections. Incoming data 

(downloading) is significantly faster than outgoing data (uploading). ADSL 

connections are expensive compared to a dial-up connection.  

 

Cable broadband – is a broadband connection that uses a modem and the cabling 

infrastructure used for cable TV to connect a computer to Internet. The cable modem 

uses the same cabling infrastructure and connection to your home as cable TV. The 

cable modem connects to the computer via a local area network (LAN) card. Cable 

connections are faster compared to dial-up connections. Incoming data 

(downloading) is significantly faster than outgoing data (uploading). The cost of a 

cable connection is similar to an ADSL connection. 

 

Wi-Fi - is a connection that uses radio transmitters and receivers to link computers. 

Many organisations and public areas provide wireless local area network hotspots 

known as Wi-Fi (Wireless Fidelity) hotspots. Users can subscribe to these 

connections. In some public areas such connections are provided at no charge. 

Nowadays many users have wireless Internet connectivity at home. Many smart 

phones support wireless connectivity.  

 

WiMAX is a wireless communications standard similar to Wi-Fi, but supports a far 

greater range of coverage. While a Wi-Fi signal can cover a radius of 30m, a fixed 

WiMAX station can cover a range of up to 50km. Mobile WiMAX stations can broadcast 

up to 16km. 

 

Mobile phone – Telecommunication companies offer subscriptions that include 

Internet on smartphones. There are different mobile Internet technologies. 



Form 10 ICT 2017/2018 

 

Page 9 of 43 
 

 

Satellite broadband – is an Internet connection that requires the installation of a 

special satellite dish. 

 

Internet Service Provider 

 

The Internet Service Provider (ISP) is a company that provides users with Internet 

connection services. ISPs provide home users with an Internet Account consisting of a 

username and a password. Users having the appropriate hardware and software will use the 

Internet Account to access the services available on the Internet. 

 

When choosing an ISP one should consider the following: 

 

 Connection Speed - The faster the speed of the broadband service the more 

expensive it will be. High speed connections will be needed when using the Internet 

to view HD-quality movies and to play multiplayer games. For light Internet surfing 

and emailing, one would not require high speed connections. 

 

ISPs quote different download/upload speeds e.g. 4Mbps/512Kbps, 5Mbps/512Kbps 

etc. to meet different user needs. The download speed (e.g. 4Mbps, 5Mbps etc) is 

how quickly you can receive information such as reading email, browsing web 

pages, downloading content such as music and photos and buffer rate when 

streaming video. The upload speed (e.g. 512Kbps) is how quickly you can send an 

email or upload photos or video to a website like Facebook, Flickr or YouTube. 

 

 Quota - ISPs may set a ‘download limit’ or quota to limit the volume of data in 

Gigabytes (GB) downloaded by users during a fixed period, usually a month. You 

will use your download quota to view web pages and receive emails etc. 

Downloading large graphic and audio files or video streams (e.g. YouTube videos) 

will use more of your download quota compared to viewing web pages or receiving 

emails. If you exceed your download limit, you might incur extra charges, or your 

ISP could limit or suspend your Internet service. 

 

 Cost - ISPs may charge a monthly subscription fee or a pay-per-use fee for use of 

the Internet Account. When choosing an ISP check also the costs of any equipment 

you might need to buy such as a modem/router or dongle (for mobile Internet).  
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Protected & Open Wireless Network 

 

If you have a laptop, you can see a list of available 

wireless networks, and then connect to one of those 

networks, no matter where you are.  

 

To view the available wireless networks: 

 Open Connect to a Network by clicking the 

network icon  or  in the notification area. A 

pop up menu will display the list of available 

wireless networks. 

 

Wireless networks can be protected/secure or open. Wireless 

networks that do not have security enabled (i.e. open 

networks) will be identified with a yellow shield icon. 

 

Note that: 

 Wireless networks appear only if your laptop has a wireless network adapter and 

driver installed and the adapter is enabled. 

 Whenever possible, you should connect to security-enabled wireless networks. If 

you do connect to an open network, be aware that someone with the right tools can 

see everything that you do, including the websites you visit, the documents you 

work on, and the user names and passwords that you use. Changing your network 

location to Public can help minimize the risk. 

 

 

To connect to a wireless network: 

1. Open Connect to a Network by clicking the network icon  or  in the 

notification area.  

2. In the list of available wireless networks, click a network, and then click Connect. 

 

Note that: 

 The first time you connect to a protected wireless network, you will need to enter a 

network security key or passphrase. 

 

Protecting Data 

 

Data security – is concerned with protecting software and data from unauthorised 

tampering or damage. IT departments often attach more importance to data protection 

rather than hardware protection. Recovery of lost data is often more expensive than 

replacing damaged hardware. 

 

Sensitive data should be safeguarded against unauthorised access. In a network 

environment, the system administrator provides a unique user ID and a password to each 

computer user. The user ID and password are needed to logon to the networked computer. 

 

Home users are able to set up a start-up password through their operating system. You 

should also set a password to unlock your screen saver. You can also set password protection 

to data files. 
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The use of a strong password enhances the security of your computer system. Your 

password should be at least 6 characters long. It should consist of both upper- and lower-

case letters and also one or more numbers. Your date of birth, phone number or any word 

that can be found in a dictionary do not constitute a strong password. Passwords should be 

changed regularly. 

 

Never share or disclose your password to any other person including colleagues, family 

members etc. Do change your password if you suspect that somebody knows it. 

 

 

Firewall 

 

A firewall is a system designed to prevent 

unauthorised access to your computer 

system when connected to Internet. A 

firewall is simply a program or hardware 

device that filters information coming 

through the Internet connection into your 

private network or computer system. If an 

incoming packet of information is flagged by 

the filters, it is not allowed through. Many 

users having always-on connections (such 

as ADSL or cable) are encouraged to install 

personal firewalls (software) that protects 

their system from intruders. 

 

 

 

Backing up Data 

 

Backing up data is the copying of data files to a secondary storage medium (USB flash 

disk, CD/DVD or magnetic tape streamer) as a precaution in case the first medium fails. 

 

Most users store large quantities of data on the hard disk without backing this on other 

storage media. It is of utmost importance to backup your data regularly. It is suggested 

that you make two backups of all your data files. 
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To be especially safe, you should keep one backup in a different location from the other – 

off-site storage. The latter protects data against theft and fire hazards. 

 

You can back up files using operating system commands, or you can buy a special-purpose 

backup utility (program). Backup programs often compress the data so that backups require 

fewer disks. 

 

Updating Software 

We strongly recommend that you turn on Windows automatic updating so that Windows can 

install security and other important or recommended updates for your computer as they 

become available. 

 

Computer programs such as operating systems, email clients, browsers, media players and 

desktop applications (e.g. wordprocessors, spreadsheets, databases etc.) may have 

vulnerable defects through which intruders can gain access to your computer. 

 

Software vendors usually release patches or hotfixes for their products when a security 

vulnerability is discovered. You must ensure that all programs on your computer are updated 

with the latest available patches. You should also check for any available updates when 

installing new software. 

 

Software patches can often be downloaded for free from the vendor's website. Some 

programs (e.g. MS Windows) have utilities which automatically connect to the vendor's 

website and download any available patches. If there is no automatic update feature for any 

of your programs, visit the vendors' website regularly and download any available updates. 

 

Energy Saving Practices 

As with all other forms of technology, information technology may impact negatively on the 

environment. All computer users should be aware of the following environmental friendly 

guidelines related to the use of computing facilities: 
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 Switch off equipment – Switch off the system unit, monitor, speakers, printer 

and scanner when these are not in use. 

 

 Automatic shutdown – You can schedule a specific time when your computer 

automatically shuts down. 

 

 Sleep mode settings - Sleep is a power-saving 

state that allows a computer to quickly resume full-

power operation (typically within several seconds) 

when you want to start working again.  

You can put your computer into sleep mode instead 

of shutting it down. When your computer is asleep, 

the display turns off and often the computer's fan 

stops. Usually, a light on the outside of your 

computer case blinks or turns yellow to indicate that 

the computer is asleep. The whole process takes 

only a few seconds. 

Because Windows will remember what you were doing, there's no need to close 

your programs and files before putting your computer into sleep mode. But it's 

always a good idea to save your work before putting the computer into any low-

power mode. The next time you turn on your computer (and enter your password, 

if required), the screen will look exactly as it did when you turned off your computer. 

To wake your computer, press the power button on your computer case. Because 

you don't have to wait for Windows to start, your computer wakes within seconds 

and you can resume work almost immediately. 

 

 Energy saving monitors – LCD-type flat screen monitors with LED backlighting 

to save on power consumption. Adjust the power management options such that 

monitors are switched off when you are away from your computer. 

 

 Minimise on paper printing & recycle paper – A lot of paper is used for printing 

purposes. Unfortunately the ease with which 

printers are able to print documents results in 

waste of a lot of paper. You should proof read 

documents before sending these to a printer. 

Also wherever appropriate, you should print two 

or four pages on a single face of an A4 paper. 

Most laser printers are also capable of printing 

on both sides of the paper. You should also print 

drafts and internal documents on paper that is 

already printed on one side. Consider 

use/storage of electronic copies instead of 

printed paper. Unwanted paper should be 

recycled. 

 

 Recycle printer cartridges – Users should purchase laser printers with longer-life 

printing drums or toners. Establish contacts with companies which buy used printer 

cartridges or toners. Use ink and toner saving settings for printing drafts and 

internal documents. 

 

 Recycle computers, devices & batteries - Establish contacts with companies 

which collect used computers, printers, batteries etc. for recycling purposes. 
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Enhancing Accessibility 

Persons with special needs make use of specific hardware and software to help them work 

on a computer. Such hardware and software is often referred to as assistive technology. 

 

 Voice recognition software is a program used to convert spoken words to text. 

The term "voice recognition" is sometimes used to refer to speech recognition where 

the recognition system is trained to a particular speaker. These programs are often 

used by persons with visibility impairment. 

 

 Screen reader is a program that reads the contents of a computer screen aloud to 

a user. Screen readers are used primarily by visually impaired persons. 

 

 Screen magnifier is a program that magnifies a portion of the computer screen, 

so that it can be more easily viewed. Screen magnifiers are used primarily by 

individuals with partial visual impairment. 

 

 On-screen keyboard is a program that displays a virtual keyboard 

on the computer screen that allows people with mobility 

impairments to type data by using a pointing device or joystick. 

Besides providing a minimum level of functionality for some people 

with mobility impairments, on–screen keyboard can also help people 

who do not know how to type.  

 High Contrast: Heightens the color contrast of some text and images on your 

computer screen, making those items more distinct and easier to identify. 

  To use a keyboard to turn High Contrast on or off, select the Turn on High Contrast 

when left ALT + left SHIFT + PRINT SCREEN is pressed check box. 
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Spreadsheets  

 

 
 
 

Saving a Workbook as another File Type 
 
 

You can save a workbook as another file type 

like: template, text file, specific file extension and 

version number. 
 

1. Click File tab. 

2. Click Save As…  The Save As dialog box is 

displayed. 

3. Select the disk and/or folder where the 

workbook file will be saved. 

4. Type a name for your workbook in the 

File name: field. 

5. Click the drop-down arrow in the Save as 

type: field. 

6. Select the file format that you want the 

file to be saved in e.g. Excel 97-2003 

Workbook. 

7. Click Save button. 
 
Note that: 

 

  The facility to save a workbook to another format can be useful so that this 

can be read by previous versions of MS Excel. 
 
 
 

 

Modifying User Preferences 

 

You can modify the author’s name attached to every workbook file generated in MS Excel 

as follows: 

1. Click File tab. 

2. Click Options. The Excel Options dialog box is displayed.  

3. Click General. 

4. In the User name: field type your name and surname. 

5. Click OK button. 
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You can also set a default folder location where all workbooks will be saved: 

1. Repeat steps 1-2 as for modifying the user name. 

2. Click Save. 

3. In the Default file location: field type the drive and folder where the workbooks will 

be saved. 

4. Click OK button. 

 

Note that: 

 When you click Open button, you will be automatically directed to the folder path 

set above. 
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Using Help 

 

1. Click Help button. The Excel Help window is displayed.  

 

 
 

2. Click one of the main topics e.g. Getting started with Excel 2010. This will display 

sub-topics. Click the sub-topic to display. 

3. You can type a keyword or question e.g. functions in the search field. 

4. Click Search button. 

5. Click the topic to display. 

6. Click Close button to close the Excel Help window. 

 

 
 

 

Using the Search & Replace Commands 

 

When you need to review or change data in your workbook, use the Find and Replace 

commands. Use Find to quickly locate occurrences of the data you specify. To change data 

use Replace command. 
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1. Select the range of cells you want to search. If you want to search 

the entire worksheet, click any cell in the worksheet.  

2. Click the Home tab. 

3. In the Editing group, click Find & Select. 

4. Click Replace... The Find and Replace dialog box is displayed. 

5. In the Find what: field, enter the text or numbers you want to search for or 

choose a recent search from the Find what: drop down box. 

 

 
 

6. Click Options button to further define your search. For example, you can 

search for all of the cells that contain the same kind of data, such as formulas.  

7. In the Replace with: field, enter the replacement characters and specific 

formats if necessary. 

8. Click Find Next button. 

9. To replace the highlighted occurrence or all occurrences of the found 

characters, click Replace button or Replace All button. 

 

Note that: 

 If you want to delete the characters in the Find what: field, leave the 

Replace with: field blank.  

 To cancel a search in progress, press ESC key. 

 

 

 

Sorting Data 

 

You can sort the data in ascending (A to Z, 0-9) or descending order (Z-

A, 9-0). 

 

1. Click a cell in the column you would like to sort by.  

2. Click the Home tab. 

3. In the Editing group, click Sort & Filter. 

4. Click Sort A to Z or Click Z to A. 

 

Note that: 

 All data in the range of adjacent cells will be sorted. 

 

 

mk:@MSITStore:C:/Program%20Files/Microsoft%20Office/Office10/1033/xlmain10.chm::/html/xlhowReplaceTextOrNumbers.htm##
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Original 

  

Sorted by Name in  

alphabetical order 

 

 

If you want to sort the data in one column only: 

1. Click the Column Heading button of the column to be sorted. 

2. Repeat steps 2-4 as above. The Sort Warning dialog box is displayed. 

3. Tick Continue with the current selection. 

4. Click Sort button. 

 

 
 

 

 

 

 
 

Original 

  

Sorted by Name in  

alphabetical order 

 

The Sort A to Z works as follows: 

Data Type Sorting Rule 

Numbers From smallest negative to largest positive. 

Dates and 

Times 

Actual values, regardless of the formatted appearance.  (April does 

not come before February, because alphabetical formatting is 

ignored). 

Text 0-9, space ! “ # $ % & ( ) * + , . / : ; < = > ? @ [ \ ] ^ _ ‘ {  } ~ 

A-Z. 

Blank cells Blank cells are last, whether the sort order is ascending or 

descending. 

 

 

 

Copying Data 

 

You can copy the content of one or more cells from one location to another, either within a 

worksheet, between worksheets or to another workbook. 
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1. Highlight the cell/s to copy. 

2. Click the Home tab.  

3. Click Copy. 

4. Select the upper-left cell of the paste area - the cells you want the 

data to be copied to - or select the entire paste area. You can click on 

a cell in a different sheet within the same workbook or open another 

workbook file. 

5. Click Paste.  

 

Note that: 

 When you click Copy, MS Excel surrounds the selected cells with a moving 

border and copies the data to the Clipboard. You can use ESC key to switch off 

the moving border. 

 

 

 

Using AutoFill Tool 

 

Sometimes you find yourself entering data in a logical sequence such as days of the week, 

month names, numbers etc. The AutoFill feature logically repeats some series as indicated 

in the following table 

 

Data type Starting series 

value 

Extended series 

Quarter abbreviated Qtr 3 Qtr 4, Qtr 1, Qtr 2 

Month names November December, 

January 

Month names 

abbreviated 

Nov Dec, Jan 

Weekday Saturday Sunday, Monday 

 

 

1. Type in the cell.  

2. Position the mouse on the fill handle of the cell. The fill 

handle is the solid, small square located in the lower-right 

corner of the selection. 

3. Drag the fill handle down or to the right. 

4. Release the mouse button at the end of the series range you 

want to create. 

 

Note that: 

 You can see the current value in the series in the reference area of the 

formula bar. This changes as you drag the fill handle. If you drag the fill 

handle further than you intended, you can drag it in the opposite direction to 

clear the unwanted values. Stop dragging at the last value you want. 

 

 

 

Moving Data 

 

You can move the content of one or more cells from one location to another, either within a 

worksheet, between worksheets or to another workbook.  

1. Select the cell/s to move. 

2. Click the Home tab.  

3. Click Cut. 
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4. Select the upper-left cell of the paste area - the cells you want the data 

to move to - or select the entire paste area. You can click on a cell in 

a different sheet within the same workbook or open another workbook 

file. 

5. Click Paste. 

 

 

 

Deleting Cell Content 

 

To delete the contents of a cell: 

1. Select the cell to delete. 

2. Press DELETE key. The cell will be emptied. 

 

Inserting & Deleting Rows & Columns 

 

To insert rows or columns: 

1. Select the cell where you want the blank row or column 

to be inserted. 

2. Click the Home tab. 

3. In the Cells group, click Insert. 

4. Click Insert Sheet Rows or Insert Sheet Columns. 

 

 

 

 

 

To delete rows or columns: 

1. Select the cells, rows or columns to delete. 

2. Click the Home tab. 

3. In the Cells group, click Delete. 

4. Click Delete Sheet Rows or Delete Sheet Columns. 

 

Freezing & Unfreezing Row & Column Titles 

 

Comparing two pieces of information at either ends of a large spreadsheet can be very 

difficult. MS Excel enables you to ‘lock in’ column and/or row titles such that these will be in 

view no matter where you scroll through your sheet. This facility of ‘locking in’ columns 

and/or rows is known as freezing. 
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Typically the column titles are in column A and the row titles are in row 1. To freeze the 

column and/or row titles: 

1. Click the View tab. 

2. In the Window group, click Freeze Panes. 

3. Click Freeze Top Row to freeze row 1. Click Freeze First Column to freeze 

column A. 

 

 
 

Note that: 

 Dark horizontal and/or vertical line/s appear on the spreadsheet. These lines 

mark the areas of the spreadsheet you have chosen to freeze. Now as you 

scroll horizontally or vertically inside the spreadsheet, the areas above and 

to the left of the dark, lines will stay on the screen while the rest of the sheet 

is allowed to scroll. 

 

 

To freeze additional rows or columns for example all rows 1 & 2 and columns A & B: 

1. Click cell C3. 

2. Click the View tab. 

3. In the Window group, click Freeze Panes. 

4. Click Freeze Panes. 

 

 

To unfreeze column and/or row titles: 

1. Click the View tab. 

2. In the Window group, click Freeze Panes. 

3. Click Unfreeze Panes. 

 

Moving, Copying & Renaming Worksheets 

 

To move or copy sheets within a workbook: 

1. Select the sheets you want to move or copy. 

2. Click the Home tab. 

3. In the Cells group, click Format. 

4. Click Move or Copy Sheet…  The Move or Copy dialog box is displayed. 
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5. In the To book: field select the workbook to receive the sheets. To move or copy 

the selected sheets to a new workbook, click new book.  

6. In the Before sheet: field select the sheet before which you want to insert the 

moved or copied sheets. 

7. To copy the sheets instead of moving them, select the Create a copy check box.  

8. Click OK button. 

 

Note that: 

 To move or copy sheets to another workbook, open the workbook that will receive 

the sheets. Repeat steps 2-8 as above. 

 You can also move a sheet within a workbook by dragging the sheet tab. 

 

 

As you start to use sheets, you will probably need to give the sheets more meaningful 

names. 

 

To rename the active sheet: 

1. Click the Home tab. 

2. In the Cells group, click Format. 

3. Click Rename Sheet. The name in the sheet tab will be highlighted. 

4. Type the new name over the current name. 

 

 
 

Note that: 

 You can also rename a sheet, by right-clicking the sheet tab card, selecting the option 

Rename and repeating step 4 as above. 

 The sheet name can consist of one or more words. The longer the name, however, 

the fewer tabs you can see at once.  

 It is a good practice to use meaningful worksheet names rather than accept default 

names. 
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Formula Error Messages 

 

MS Excel displays error messages when your formula/function cannot do the calculation. 

The following are some standard error messages associated with formulae: 

 

Error  Explanation 

##### The cell contains a number or calculation result that is too wide for the cell to 

display. Adjust the column width to accommodate the result. 

#VALUE! The formula contains text (or a cell reference that points to a cell containing text) 
instead of a number. Edit the formula or cell to sort this problem. 

#REF! Probably the formula contains a cell reference that points to an invalid cell (the cell 

could have been deleted). 

#NAME? MS Excel does not recognise text contained within a formula. 

#DIV/0 The formula divides a number by zero or by a cell reference that points to a cell 
containing a zero. The same message is displayed if you divide a number by a cell 

reference that points to an empty cell. 
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Relative & Absolute Cell Referencing 

 

Consider the example displayed on the next page, you can use the AutoFill feature to copy 

formulae from one cell to another. 

 

1. Click in the cell where the answer will be placed e.g. C8. 

2. Type the formula =C5+C6+C7 to calculate the total expenses.   

3. Use AutoFill to replicate the function on cells D8. 

 

Note that: 

 Cell D8 displays the answer. If you click this cell, the formula bar displays the 

formula used to calculate the answer. 

 

However you need to use the AutoFill with caution when replicating formulas and functions. 

If you calculate the tax rate in cell C14 and then drag the formula to D14, E14 and F14 you 

will get strange answers. Click in the cell where the answer will be placed e.g. in C14 and 

type the formula =C10*B14 to calculate the tax rate on the Profit. Now drag the formula 

using the AutoFill handle to cell D14. The first answer will be correct (140) but the second 

one is definitely incorrect (308000). What happened? 

 

 A B C D 

1 Income    

2 Total Sales  4000 5000 

3     

4 Expenses    

5 Cost of Goods Sold  1500 1800 

6 Advertising  300 350 

7 Rent  450 650 

8 Total Expenses    

9     

10 Profit or Loss    

11     

12 Average Expenses    

13     

14 Tax Rate  8%   

15     

 

 

When you dragged the formula  =C10*B14  to cell D14, the computer created the formula  

=D10*C14. MS Excel adjusted the formula according to its new position - this is called 

relative referencing.  

 

However, in your example you expected MS Excel to continue to refer to the same tax rate. 

Therefore you have to modify the formula to continue referring to a specific cell called 

absolute referencing. 

 

Absolute cell references allow you to continue to refer to a cell, no matter where you copy 

a formula.  You create an absolute cell reference by entering dollar signs ($) before each 

part of a cell reference of a formula you want to copy.  The above tax rate formula will be 

modified to  =C10*$B$14. 

 

Therefore: 

 A relative cell reference is a reference to a cell in the format A1. MS Excel changes 

a relative cell reference when you copy a formula or function containing such a 

reference. 



Form 10 ICT 2017/2018 

 

Page 26 of 43 
 

 An absolute cell reference is a reference to a cell in the format $A$1. MS Excel does 

not adjust an absolute cell reference when you copy a calculation containing such 

a reference.  

 

 

 

Arithmetic Functions 

 

Functions, like formulae, allow you to perform calculations using values from any cell/s in a 

spreadsheet. You will use the following common functions: 

 

sum(  ) average(  ) count(  ) 

min(  ) max(  ) round(  ) 

 

There are some basic rules associated with functions: 

 Functions always begins with an equal (=) sign. 

 Cells are referenced in a function by their column-row identifier, i.e. A1, B2 etc. 

 You do not have to enter capital letters in your function; MS Excel will automatically 

capitalize them for you. 

 Function cannot contain spaces. 

 Always press ENTER key to confirm your function. The answer to the function 

displays in the cell into which the function is entered. 

 

 

Sum Function 

 

Consider the following sheet: 

 A B C D 

1 Income    

2 Total Sales  4000 5000 

3     

4 Expenses    

5 Cost of Goods Sold  1500 1800 

6 Advertising  300 350 

7 Rent  450 650 

8 Total Expenses    

9     

10 Minimum Expense    

11 Maximum Expense    

12 Average Expenses    

13     

 

1. Click the cell where the answer will be placed e.g. C8 

2. Enter the function: =sum(C5:C7) 

3. Press ENTER key. 

 

Note that: 

 The answer will be displayed in the cell where you entered the function. 

 You can still see the function in the formula bar. 

 Using the sum function facilitates the addition of a range of cells. The function in 

the above example tells the computer to add the contents of cells C5 to C7. 

 

 

You can use the AutoSum function to add the contents of a range of cells: 
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1. Click the cell where the answer will be placed e.g. C8 

2. Click the Home tab. 

3. In the Editing group, click AutoSum. 

4. Click Sum. 

5. Highlight the cells to add their values by dragging the 

mouse. 

6. Press ENTER key. 

 

 

Minimum Function 

 

The Minimum function returns the smallest value in a range of cells. 

1. Click the cell where the answer will be placed e.g. C10 

2. Enter the function: =min(C5:C7) 

3. Press ENTER key. 

 

 

Maximum Function 

 

The Maximum function returns the largest value in a range of cells. 

1. Click the cell where the answer will be placed e.g. C11 

2. Enter the function:  =max(C5:C7) 

3. Press ENTER key. 

 

 

Average Function 

 

The Average function returns the average (arithmetic mean) of a range of cells. 

1. Click the cell where the answer will be placed e.g. C12 

2. Enter the function  =average(C5:C7) 

3. Press ENTER key. 

 

 

Count Function 

 

Sometimes you may wish to count values or worksheet elements (text, blank cells, specific 

number or text, etc.) in a spreadhseet. A "counting" function will return the number of cells 

in a range that meet certain criteria.  

 

The COUNT function works out how many cells in a given range contain numbers (including 

dates and formulae with numerical answers). It ignores blank cells and cells containing text, 

logical or error values. 
 

=COUNT(value1,value2,…) 

 

where value1, value2,... are 1 to 30 arguments that can contain or refer to a variety of 

different types of data, but only numbers are counted. 
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Consider the following example: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Counta Function 

 

The COUNTA function counts the number of cells that contain any type of value - numbers, 

text, error text etc. It does not include empty cells. 
 

=COUNTA(value1,value2,…) 

 

where value1, value2,... are 1 to 30 arguments representing the values you want to 

count. 

 

Consider the following example.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Round Function 

 

The ROUND function rounds a number to a specified number of digits. 
 

=ROUND(number,num_digits) 

 

where  number is the number you want to round. 

Num_digits specifies the number of digits to which you want to round 

 number. 

Note that: 

 If num_digits is greater than 0 (zero), then number is rounded to the specified 

number of decimal places. 

 If num_digits is 0, then number is rounded to the nearest integer. 

 If num_digits is less than 0, then number is rounded to the left of the decimal 

point.  

Formula Description (Result) 

=COUNT(A2:A8)  Counts the number of cells that contain 
numbers in the list (3). 

=COUNT(A5:A8)  Counts the number of cells that contain 
numbers in the last 4 rows of the list (2). 

=COUNT(A2:A8,2)  Counts the number of cells that contain 
numbers in the list, and the value 2 (4) 

Formula Description (Result) 

=COUNTA(A2:A8)  Counts the number of nonblank cells in 
the list (6). 

=COUNTA(A5:A8)  Counts the number of nonblank cells in 
the last 4 rows of the list (4). 

=COUNTA(A1:A7,2)  Counts the number of nonblank cells in 
the list above and the value 2 (7). 

=COUNTA(A1:A7,"Two")  Counts the number of nonblank cells in 
the list above and the value "Two" (7). 
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Formula Description (Result) 

=ROUND(2.15, 1)  Rounds 2.15 to one decimal place (2.2) 

=ROUND(2.149, 1)  Rounds 2.149 to one decimal place (2.1) 

=ROUND(-1.475, 2)  Rounds -1.475 to two decimal places (-1.48) 

=ROUND(21.5, -1)  Rounds 21.5 to one decimal place to the left of the decimal point (20) 

 

 

 

Using the Logical Function IF 

 

The logical function IF (also known as the IF statement) tells MS Excel what to place in a 

cell (text, number or calculation) if certain defined parameters are either met or not met. 

 

Consider the following values A=5 and B=6. The results of the following logical tests are: 

Operators Symbol Values for Evaluation Result 

Equal to = A=B FALSE 

Not equal to <> A<>B TRUE 

Greater than > B>A TRUE 

Less than < B<A FALSE 

Greater than or equal to >= B>=A TRUE 

Less than or equal to <= B<=A FALSE 

 

The IF( ) function decides the contents of a cell on a spreadsheet based on whether a test 

condition is TRUE or FALSE. It returns a value if a one condition is TRUE, and another 

value or result if the condition is FALSE. 

 

The IF( ) function is written as: 

IF(logical_test, value_if_true, value_if_false) 

 

where:  logical_test is any value or expression that can be evaluated to TRUE or FALSE. 

 value_if_true is the value returned if the logical test is TRUE. 

 value_if_false is the value returned if the logical test is FALSE. 

 

 

Example 1: 

 A B C 

1 Part No. Amount Available 

2 542013B 4 Yes 

3 190802A 0 No 

4 121271C 10 Yes 

 

The spreadsheet uses the IF() function to display a message in column C depending on the 

Amount for each part which is recorded in column B. If the Amount is 0 column C displays 

‘No’ otherwise it displays ‘Yes’. 

 

The formula in C2 is written as follows: =IF(B2=0, “No”, “Yes”) 

The logical_test is B2=0 

The value_if_true is “No” 
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The value_if_false is “Yes”   

 

 

Example 2: 

 A B C 

1 Part No. Amount Ordered 

2 542013B 4 On order 

3 190802A 0 On order 

4 121271C 10 No 

 

The spreadsheet uses the IF() function to display a message in column C depending on the 

Amount for each part which is recorded in column B.  If the Amount is less than 5, column 

C displays ‘On order’ otherwise it displays ‘No’. 

 

The formula in C2 is written as follows: =IF(B2<5, “On order”, “No”) 

The logical_test is B2<5 

The value_if_true is “On order” 

The value_if_false is “No”   

 

 

Example 3: 

 A B C 

1 Student Average Mark Pass/Fail 

2 Borg Jan 55 Pass 

3 Callus Mario 44 Fail 

4 Portelli Carlo 78 Pass 

 

The spreadsheet uses the IF() function to display a message in column C depending on the 

Average Mark obtained by a student.  If the Average Mark is equal to or greater than 45, 

column C displays ‘Pass’ otherwise it displays ‘Fail’. 

 

The formula in C2 is written as follows: =IF(B2>=45, “Pass”, “Fail”) 

The logical_test is B2>=45 

The value_if_true is “Pass” 

The value_if_false is “Fail” 

 

 

Example 4: 

 A B C 

1 Staff Sales Commission @ 2% 

2 Bartolo Carol 500 10 

3 Felice Philip 255 5.1 

4 Zammit Lourdes 210 0 

 

The spreadsheet uses the IF() function to display a message in column C depending on the 

Sales made by each staff.  If the Sales is equal to or greater than 250, column C displays a 

2% commission of the sales otherwise it displays ‘0’. 

 

The formula in C2 is written as follows: =IF(B2>=250, B2*2%, 0) 

The logical_test is B2>=250 

The value_if_true is the answer returned by B2*2% 

The value_if_false is “0” 
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 FORMATTING 
 

Formatting Cells 

 

By default, MS Excel uses the General format for numbers that you type in cells. The General 

format has the following characteristics: 

 Zeros are not displayed after the decimal point – if you 

type 23.50 this will be displayed as 23.5. 

 Thousand numbers are not separated by the comma 

symbol – if you type 4,000 this will be displayed as 4000. 

 

You can use several methods to change the formatting of numbers. Several number format 

features are available through the Home tab. 

 

Option Button To Do 

Currency 
 

Puts the default currency style on the left; puts a decimal 
point at the end; displays two numbers to the right of the 
decimal point; adds commas to separate thousands. 

Percent 
 

Displays the number as a percentage with no decimals. 

Comma 
 

Separates thousands with a comma; adds a decimal point; 
displays two digits to the right of the decimal point. 

Increase Decimal 

 

Increases the number of characters (numbers) to the right 

of the decimal point by one. 

Decrease Decimal 

 

Decreases the number of characters (numbers) to the right 
of the decimal point by one. 

 

 

To format numbers: 

1. Highlight the cell/s you want to format. 

2. Click the Home tab. 

3. In the Number group, click Currency, Percent, Comma, Increase Decimal or 

Decrease Decimal. 

 

You can also format numbers as follows: 

1. Highlight the cell/s you want to format. 

2. Click the Home tab. 

3. In Number group, click the Format Cells Dialog Launcher. The Format Cells 

dialog box is displayed. 

4. Click Number tab. 

5. Select a format category from the Category: list box. The listing of format codes 

changes to reflect the category you choose. 

6. Select the appropriate numeric format code. The Sample information box shows a 

sample of the format applied to the current cell’s contents. 

7. Click OK button. 
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To format cells to display a date style: 

1. Repeat steps 1-4 as above. 

2. Click Date below the Category: list box. 

 
3. Select the appropriate option in the Locale (location): drop down menu. 
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4. Click the appropriate date style in the Type: list. 

5. Click OK button. 

 

 

 

Copying Cell Formatting 

 

You can copy the formatting (typestyles, fonts etc.) of characters in a cell to other cell/s as 

follows: 

1. Click the Home tab. 

2. Highlight the cell containing the formatting you want to copy. 

3. In the Clipboard group, click Format Painter. 

4. Drag the mouse to highlight the cell/s to which you want to 

apply the formatting. 

Applying Text Wrapping within Cells 

 

You can apply text wrapping to contents within a cell or a cell range: 

1. Click the Home tab. 

2. Select the cell/s that you want to apply text wrapping to.  

3. In the Alignment group, click Wrap Text.  

 

 

 

Aligning Cell Content 

 

By default, MS Excel aligns text to the left edge of a cell and values (numbers, dates, time) 

to the right edge of a cell. There are three horizontal alignment options in MS Excel: 

 

Option Button Effect 

Align Left 
 

Aligns data to the left edge of the cell. If the data does not fit, 
excess data is placed in the cell to the right (if that cell is empty). If 

the cell to the right is not empty, the display of the data ends at 
the right edge of the cell. 

Centre 
 

Aligns data in the centre of the cell. Spill over data appears in the 
adjoining cells if either or both are empty. Otherwise, the display of 
the data is truncated. 

Align Right 
 

Aligns data to the right edge of the cell. Spill over data appears in 
the cell to the left if it is empty. Otherwise, the display of the data 
is truncated.   

 

 

To change the horizontal alignment (left, centre, right) of data in a cell/s: 

1. Click the Home tab. 

2. Highlight the cell/s. 

3. In the Alignment group, click Align Left, Centre or Align Right. 

 

 

The alignment options indicated above allow you to position cell contents horizontally (left-

to-right). MS Excel also allows you to align cells vertically (top-to-bottom): 

 

1. Click the Home tab. 
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2. Highlight the cell/s. 

3. In the Alignment group, click Top Align, Middle Align or 

Bottom Align. 

 

 

To adjust the cell content orientation: 

1. Click the Home tab. 

2. Highlight the cell/s. 

3. In the Alignment group, click Orientation. 

4. Click the appropriate option or Format Cell 

Alignment. The Format Cells dialog box is displayed. 

5. In the Degrees field enter a number. 

6. Click OK button. 

 
 

 

The following table outlines all the available options in the Alignment tab in the Format Cells 

dialog box. 

 

Option To Do This 

Horizontal Aligns text to the left, numbers to the right, and centres logical and error 

values. 

Left (Indent) Aligns cell contents to the left. 

Center Centres cell contents. 

Right Aligns cell contents to the right. 

Fill Repeats the contents of the selected cell until the cell is full. If blank cells to 
the right also have the Fill alignment, they are filled as well. 

Justify Aligns wrapped text within a cell to the right and left. You must have more 
than one line of wrapped text to see the justification. 



Form 10 ICT 2017/2018 

 

Page 35 of 43 
 

Option To Do This 

Center Across 
Selection 

Centres a cell entry across the selected cells. 

Vertical  

Top Aligns cell contents along the top of the cell. 

Center Centres cell contents in the middle of the cell. 

Bottom Aligns cell contents along the bottom of the cell. 

Justify Justifies the cell contents up and down within the width of the cell. 

Wrap text Wraps text into multiple lines in a cell. The number of wrapped lines is 

dependent on the width of the column and the length of the cell contents. 

Shrink to fit Reduces the apparent size of font characters so that all data in a selected cell 
fits within the column. The character size is adjusted automatically if you change 
the column width. The applied font size is not changed. 

Merge cells Combines two or more selected cells into a single cell. The cell reference for a 
merged cell is the upper-left cell in the original selected range. 

Orientation Rotates selected cell entries. 

 

 

 

Merging Cells 

 

You can join (merge) two or more cells and centre text (e.g. a title) in the merged cells: 

1. Click the Home tab. 

2. Highlight the cells across which the data will be centred. 

3. In the Alignment group, click Merge & Center. 

 

 
 

 

To remove merging: 

1. Click the Home tab. 

2. Highlight the cell to unmerge. 

3. In the Alignment group, click Merge & Center. 

4. Click Unmerge Cells. 

 

 

 

Adding Border Effects 

 

You can add border effects to a cell/s: 

1. Click the Home tab. 

2. Highlight the range of cells to add border to. 

3. In the Font group, click Borders.  
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4. Choose the appropriate option or More Borders… The Format Cells dialog box is 

displayed. 

5. Click the appropriate Style: below Line. 

6. Click the colour for the line border. 

7. Click the appropriate button below Border. 

8. Click OK button. 
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 CHARTS 

 

Creating & Selecting Charts 

 

A chart/graph is a graphical representation of the numeric data in a worksheet. Each cell (or 

piece of data) represented in the chart is called a data point. Data points are represented 

on the chart by bars, columns, lines, or some other graphical device. A group of related data 

points is called a data series. 

 

Name English Maltese Maths 

Anthony 55 80 74 

Maria 63 43 84 

Philip 62 57 65 

Rita 43 7 95 

 

 

 



Form 10 ICT 2017/2018 

 

Page 38 of 43 
 

Typically, values are plotted along the vertical plane (y-axis) and categories are plotted 

along the horizontal plane (x-axis). Labels that run horizontally under the various data series 

and display the categories represented are x-axis labels. Labels running vertically and listing 

the value increments are the y-axis labels. 

 

 

To create a chart: 

1. Highlight the data to be included in the graph. 

2. Click the Insert tab. 

3. In the Chart group, click the type of chart to use e.g. Column, Line, Pie, Bar etc. 

4. Click the sub-type of chart to use. 

 

 
 

 

To select a chart: 

Click anywhere in the chart. This displays the Chart Tools, adding the Design, 

Layout, and Format tabs. 

 

 

 

Changing the Chart Type 

 

You can change the type of chart in a slide: 

1. Click the chart in the slide. 

2. Click the Design tab, under Chart Tools. 

3. In the Type group, click Change Chart Type. The Change Chart 

Type dialog box is displayed. 

4. Select the type of chart to use e.g. Pie.  

5. Click the chart sub-type. 

6. Click OK button.  
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Moving, Resizing & Deleting Charts 

 

To move a chart in a new worksheet: 

1. Select the chart to move. 

2. Click the Design tab below Chart Tools. 

3. Click Move Chart. The Move Chart dialog box. 

 

 
 

4. Click New sheet: option. 

5. Enter a title for the sheet in the text box provided. 

6. Click OK button. 

 

 

To move a chart to a different sheet or workbook: 

1. Click the Home tab. 

2. Click anywhere in the chart to move. 

3. Click Cut (to move).   

4. Click in the sheet or workbook where the chart will be copied. 

5. Click Paste. 

 

To resize a chart: 
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1. Click anywhere inside the chart.  

2. Position the pointer on one of the corner handles. The pointer changes to a double-

headed arrow. 

3. Drag the mouse to resize the chart. 

 

 

To delete a chart: 

1. Click anywhere inside the chart. 

2. Press DELETE key. 

 

 

 

Adding, Editing & Removing Chart Titles 

 

To add a chart title: 

1. Click the chart to add a title to. 

2. Click the Layout tab, under Chart Tools. 

3. In the Labels group, click Chart Title. 

4. Click Above Chart. A placeholder with the text 

‘Chart Title’ is displayed. 

5. Click in the placeholder.  

6. Edit the text in the title placeholder. 

 

 

To edit a chart title: 

1. Click the chart title placeholder. 

2. Edit the text in the title placeholder. 

 

 

To delete a chart title: 

1. Click the chart title placeholder. 

2. Press DELETE key. 

 

 

 

Adding Data Labels 

 

You can add two kinds of labels to a chart: 

 Value Labels – these indicate the numerical 

values of the individual data points. 

 Text Labels – these display the names of the data 

points.  By default, Excel already displays these 

names on an axis. 

 

 

To add data labels to a chart: 

1. Click the chart to add labels to. 

2. Click the Layout tab, under Chart Tools. 

3. In the Labels group, click Data Labels. 

4. Click the appropriate option. 

 

 



Form 10 ICT 2017/2018 

 

Page 41 of 43 
 

Changing Chart Colours 

 

You can modify the colours of the chart area, plot area and data series: 

1. Click the chart. 

2. Click the Format tab, under Chart Tools. 

3. In the Current Selection group, click the drop down arrow 

and choose Chart Area, Plot Area, Legend or any data 

series. 

4. In the Shape Styles group, click Shape Fill.  

5. Select a standard colour or choose More Fill Colours… The Colors dialog box is 

displayed. 

6. Select a colour. 

7. Click OK button.  

 

 

 

Changing the Font Size & Colour of Chart Text 

 

You can modify the font size and colour of chart title, chart axes and chart legend text:  

1. Click the chart. 

2. Click the Format tab, under Chart Tools. 

3. In the Current Selection group, click the drop down arrow and choose Chart Title, 

Horizontal (Category) Axis or Vertical (Value) Axis. 

 

 
 

4. Click the Home tab. 

5. In the Font group: 

Click the drop-down arrow of the Font Size box. 

Select the appropriate size.  

 

In the Font group, click Font Colour drop-down arrow. 

Choose the colour to apply OR click More Colours… The Colours dialog box is 

displayed. Click the colour to apply. Click OK button. 

 

 

 PREPARE OUTPUTS 
Inserting & Deleting Fields in Headers & Footers 

 

You can insert fields such as page numbering information, date, time file name and 

worksheet name into the headers and footers: 

1. Click the Insert tab. 

2. In the Text group, click Header & Footer. The screen will display a 

text placeholder in the Header section. 
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3. In the Design tab, below Header & Footer Tools, click the appropriate field in the 

Header & Footer Elements group to insert fields in the header text placeholder. 

 

 
 

4. In the Navigation group, click Go to Footer.  

5. Click the appropriate field in the Header & Footer Elements group to insert 

fields in the footer text placeholder. 

 

 

To delete data in headers or footers: 

1. Repeat steps 1-2 as above. 

2. Edit or delete the data displayed in the header or footer. 

 

Printing 

 

To print a selected cell range from a worksheet: 

1. Highlight the cell range to print. 

2. Click File tab. 

3. Click Print. The Backstage view is displayed. 

4. In the Settings section, click Print Selection. 

5. Click Print button. 

               
 

 

To print an entire worksheet or entire spreadsheet: 

1. Click File tab. 

2. Click Print. The Backstage view is displayed. 

3. In the Settings section: 

To print the entire worksheet, click Print Active Sheets. 

To print the entire spreadsheet file, click Print Entire Workbook. 

4. Click Print button. 

 

 

To print a selected chart: 

1. Select the chart to print. 

2. Click File tab. 

3. Click Print. The Backstage view is displayed. 

4. In the Settings section, click Print Selected Chart. 
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5. Click Print button. 

 

 

To print multiple copies of a worksheet: 

1. Click File tab. 

2. Click Print. The Backstage view is displayed. 

3. Next to the Print button, set/type the number of copies in the Copies box. 

 

 
 

4. Click Print button.  

5. Click the File tab to return to the Print Layout view. 

 

 
 
 
 

 


